JPRED-2 Add sources of all binaries (except alscript) to Git
[jpred.git] / sources / pairwise / Pairwise / Makefile.PL
diff --git a/sources/pairwise/Pairwise/Makefile.PL b/sources/pairwise/Pairwise/Makefile.PL
new file mode 100644 (file)
index 0000000..5274ab4
--- /dev/null
@@ -0,0 +1,17 @@
+use 5.008;
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+    'NAME'             => 'Pairwise',
+    'VERSION_FROM'     => 'Pairwise.pm', # finds $VERSION
+    'PREREQ_PM'                => {}, # e.g., Module::Name => 1.1
+    ($] >= 5.005 ?    ## Add these new keywords supported since 5.005
+      (ABSTRACT_FROM => 'Pairwise.pm', # retrieve abstract from module
+       AUTHOR     => 'Jonathan Barber <jon@compbio.dundee.ac.uk>') : ()),
+    'LIBS'             => [''], # e.g., '-lm'
+    'DEFINE'           => '', # e.g., '-DHAVE_SOMETHING'
+    'INC'              => '-I.', # e.g., '-I. -I/usr/include/other'
+       # Un-comment this if you add C files to link with later:
+    # 'OBJECT'         => '$(O_FILES)', # link all the C files too
+);