JWS-117 Compiled all tools with ./compilebin.sh and some were missing related files.
[jabaws.git] / binaries / src / ViennaRNA / misc / PKGBUILD
1 # Maintainer: Ronny Lorenz <ronny at tbi dot univie dot ac dot at>
2
3 pkgname=viennarna2
4 pkgver=2.1.2
5 pkgrel=1
6 pkgdesc="RNA Secondary Structure Prediction and Comparison"
7 arch=('armv7h' 'i686' 'x86_64')
8 license=('Custom')
9 url="http://www.tbi.univie.ac.a/~ivo/RNA"
10 depends=('perl')
11 optdepends=('perl: usage of the utility programs and perl interface to the RNAlib'
12 'python2: python2 interface to the RNAlib'
13 'ruby: ruby interface to the RNAlib')
14 conflicts=('viennarna')
15 makedepends=()
16 provides=('Kinfold=1.3')
17 source=(http://www.tbi.univie.ac.at/~ronny/programs/ViennaRNA-${pkgver}.tar.gz)
18
19 md5sums=('')
20
21 build() {
22   cd "${srcdir}/${pkgname}-${pkgver}"
23   # forester does not compile (g2 breaks at DESTDIR)
24   ./configure --with-cluster --prefix=/usr --without-forester || return 1
25   make || return 1
26 }
27
28 package() {
29   cd "${srcdir}/${pkgname}-${pkgver}"
30   make DESTDIR="${pkgdir}" install || return 1
31   # no need for that file
32   rm $pkgdir/usr/share/info/dir
33 }